О системе

Система предназначена для контроля поручений подразделений ПетрГУ, с целью упрощения и повышения эффективности работы выполнения поручений организационного отдела.

Разработчики

  • Аверкина Оксана
  • Белоусов Андрей
  • Глушонкова Юлия
  • Матвеев Игорь
  • Талбонен Андрей
  • Эйнтроп Виталик


Система учета поручений подразделений ПетрГУ

Вход в систему

Для входа в систему необходимо ввести свои логин и пароль.

В систему можно войти на правах обычного пользователя или администратора.

Пользователь
  1. Работа с БД (добавление, изменение, редактирование данных);
  2. Возможность снятия распоряжения с контроля в ручную;
  3. Изменение шаблонов писем;
  4. Осуществление печати текущего вида таблицы распоряжений;
  5. Просмотр выполненных распоряжений;

Администратор
  1. Выполнение действий обычного пользователя;
  2. Изменение настроек сервера;
  3. Работа с таблицей пользователей;


Регистрация новых пользователей

Регистрация новых пользователей (для администратора системы)

Если Вы являетесь администратором системы то Вам доступна форма управления пользователями всей системы.

Для добавления нового пользователя необходимо ввести в соответствующие поля его логин и пароль (2 раза).

На форме располагаются кнопки для удаления и добавления новых пользователей.


Главная форма

На главной форме представлены меню "Таблицы", "Настройки" и "Справка". В меню "Таблицы" представлен список возможных таблиц:
  1. Таблица поручений

  2. Таблица сотрудников

  3. Таблица пользователей (с ней может работать только пользователь на правах администратора, для всех остальных, она неактивна)

  4. Таблица приоритетов

  5. Таблица групп сотрудников


Форма шаблонов

Шаблоны писем
Пользователь может
  • Создавать новые шаблоны
  • Редактировать уже имеющиеся
  • Удалять шаблоны

    Создание новых шаблонов:
    Осуществляется нажатием на соответствующую кнопку ("плюс"). Справа, в пустой области, можно создавать любой шаблон, вводить соответствующий текст.

    Редактирование уже существующих шаблонов
  • Выбирается шаблон из списка слева, который необходимо корректировать.
  • Данный шаблон отображается в области слева, в которой осуществляется редактирование.

    Удаление шаблонов

    Выбираются те шаблоны, которые необходимо удалить. Нажатие на соответствующую кнопку ("красный крест") , приводит к удалению шаблонов.


Работа с поручениями

Таблица поручений

Добавление новых данных:
  1. Осуществляется нажатием на соответствующую кнопку ("плюс"). Курсор перемещается в самый низ таблицы на свободную строку, в которую непосредственно и вводятся данные
  2. Справа от таблицы устанавливаем дату поступления и конечный срок исполнения поручения

Редактирование данных
  1. Выбирается строка, в которой необходимо редактировать данные
  2. Корректировка осуществляется непосредственно в таблице

Удаление записей

Выделяются те записи, которые необходимо удалить. Нажатием на соотвествующую кнопку ("красный крест") удаляются соответствующие записи в таблице.

Снятие поручения с учета

Необходимо выделить те поручения, которые необходимо снять с учета. Нажатие на кнопку "снять с учета", приведет к тому, что поручения будут сняты с выполнения. После этого поручения (т.е. соответствующая запись в таблице) перемещаются в таблицу "Выполненные распоряжения".

Печать поручений

Появляется соответсвующая форма "Печать", поскольку в таблице много записей, то для удобства предлагается выбрать поля по которым сортировать таблицу, только после это, результат сортировки можно распечатать.

Разослать напоминания

Необходимо выделить те поручения, напоминание о которых хотелось бы, чтобы отправилось. Нажатие на кнопку приведет к отправке напоминаний.
Выполненные поручения


Работа с данными

  • Таблица "Сотрудники"

    В этой таблице отображаются все сотрудники, сведения о которых имеются в базе данных программной системы. Работа с таблицой осуществляется посредством кнопок "Плюс"/"Красный крест", добавление/уаление записи соответственно. При нажатии на кнопку "Закрыть", произойдет возврат на главную форму (таблица "Поручений")

  • Таблица "Пользователи" Описание работы с таблицей приводится здесь

  • Таблица приоритетов

    Содержит все имеющиеся приоритеты. Работа с данными посредством кнопок "Плюс"/"Красный крест", добавление/уаление записи соответственно. При нажатии на кнопку "Закрыть", произойдет возврат на главную форму (таблица "Поручений")

  • Таблица групп сотрудников

    Аналогично.

  • Таблица "История действий сервера"

    Таблица открыта только для чтения. Изменять/удалять данные из таблицы пользователь не может. При нажатии на кнопку "Закрыть", произойдет возврат на главную форму (таблица "Поручений")